Durante la habilitación de la nómina electrónica se puede generar algunos errores. Aplica el correcto procedimiento para evitar el batch.ZipKey.
El TestSetID es el código único identificador de prueba que se necesita para enviar la documentación exigida por la DIAN. Este es un procedimiento previo de la validación antes de la transferencia de la nómina electrónica y en ocasiones se generar un error de habilitación por no estar correctamente registrado el TestSetID. Veamos cómo solucionarlo.
Causa
Cuando ocurre este error en la habilitación de nómina electrónica, se debe a que el código ingresado TestSetID no es correcto.
Solución
Este código debe ser exacto, no puede tener espacios ni ningún otro carácter diferente a los generados por la DIAN. Debe consultar de nuevo este código en el sistema de la DIAN y copiarlo de manera exacta.
En este artículo encontrará una guía para generar un nuevo código de habilitación (testsetid) en la DIAN (haga clic aquí)
El error completo generado por la DIAN es como se observa a continuación:
Error al procesar batch. ZipKey: (código zipkey eliminado) at
System.ThrowHelper.ThrowKeyNotFoundException() at
System.Collections.Generic.Dictionary`2.get_Item(TKey key) at
Gosocket.Dian.Functions.Batch.ProcessBatchDocumentsZipFile.ValidateXpathValues at
Gosocket.Dian.Functions.Batch.ProcessBatchDocumentsZipFile.d__16.MoveNext()